Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

[Composer]get not found package from documentation

edited October 2012 in Install Help

Hello, a tried to install apps and third party package from composer but only returning error like this

Installing dependencies Your requirements could not be resolved to an installable set of packages.

Problem 1 - The requested package elefant/app-analytics * could not be found. Problem 2 - The requested package elefant/app-form * could not be found. Problem 3 - The requested package elefant/theme-bootstrapped * could not be found.

Potential causes: - A typo in the package name - The package is not available in a stable-enough version according to your minimum-stability setting see https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion for more details.

How to fix it, actually it's my first time using elefant and composer

Regards.

Comments

  • Ok Sory, i fixed it myself

    My composer.json are

    { "require": { "elefant/app-installer": "dev-master", "elefant/theme-installer": "dev-master", "elefant/app-form": "dev-master", "elefant/app-filepicker": "dev-master", "elefant/app-comments": "dev-master", "elefant/app-chat": "dev-master", "elefant/app-faq": "dev-master", "elefant/app-dbman": "dev-master", "elefant/app-events": "dev-master" }, "config": { "vendor-dir": "lib/vendor" } }

    it's dependency/requirements problem after all. :D

  • Looks like not providing version numbers in the apps/themes is now causing this problem. I'll update those soon, but for now it appears either of these are required:

    Add a "minimum-stability": "dev" line:

    {
        "require": {
            "elefant/app-analytics": "*",
            "elefant/app-dbman": "*",
            "elefant/app-form": "*",
            "elefant/theme-bootstrapped": "*"
        },
        "config": {
            "vendor-dir": "lib/vendor"
        },
        "minimum-stability": "dev"
    }
    

    Or specify "dev-master" instead of "*":

    {
        "require": {
            "elefant/app-analytics": "dev-master",
            "elefant/app-dbman": "dev-master",
            "elefant/app-form": "dev-master",
            "elefant/theme-bootstrapped": "dev-master"
        },
        "config": {
            "vendor-dir": "lib/vendor"
        }
    }
    
  • And the apps/themes should work with "*" or "1.0" now too :)

Sign In or Register to comment.