Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Can't install apps

edited October 2012 in Apps

Hi.

I dont seem to be able to install apps. I unzip it in my apps/ folder and when I launch the app from admin section it says:

Page not found

Hmm, we can't seem to find the page you wanted at the moment.

apps/ folder is set to 777.

Comments

  • I have tried to install Google sitemaps and Analyctics.

  • Try setting the permissions for the apps folder recursively to 777 so that all subfolders and files underneath it get set to 777 as well

  • I have tried setting it to chmod -R 777 apps/

    Is this what u mean?

  • Yes...that is what I meant. And no luck on install? Are these apps from ElefantCMS developers that you are trying to install?

  • No luck with that. Yes installed them from github.

  • Are the pre-installed apps (blocks, blog posts, etc) working correctly for you?

  • yes - they work perfect.

  • Hmm, can you paste the output of running ls -al apps from the root of your site?

  • edited October 2012

    plussokonomi@fredrik:~/public_html$ ls -al apps
    total 60
    drwxrwxrwx 14 plussokonomi plussokonomi 4096 Oct 16 16:02 .
    drwxr-xr-x 14 plussokonomi plussokonomi 4096 Oct 16 13:45 ..
    drwxrwxrwx 10 plussokonomi plussokonomi 4096 Oct 15 19:52 admin
    drwxrwxrwx 9 plussokonomi plussokonomi 4096 May 11 06:37 analyctics
    drwxrwxrwx 5 plussokonomi plussokonomi 4096 Oct 15 19:52 api
    drwxrwxrwx 7 plussokonomi plussokonomi 4096 Oct 15 19:52 blocks
    drwxrwxrwx 10 plussokonomi plussokonomi 4096 Oct 15 19:52 blog
    drwxrwxrwx 8 plussokonomi plussokonomi 4096 Oct 15 19:52 designer
    drwxrwxrwx 8 plussokonomi plussokonomi 4096 Oct 15 19:52 filemanager
    -rwxrwxrwx 1 plussokonomi plussokonomi 67 Sep 13 16:13 .htaccess
    drwxrwxrwx 8 plussokonomi plussokonomi 4096 Oct 15 19:52 navigation
    drwxrwxrwx 5 plussokonomi plussokonomi 4096 May 11 07:30 sitemaps
    drwxrwxrwx 5 plussokonomi plussokonomi 4096 Oct 15 19:52 social
    drwxrwxr-x 4 plussokonomi plussokonomi 4096 Oct 16 16:03 test
    drwxrwxrwx 9 plussokonomi plussokonomi 4096 Sep 13 16:13 user

    my apache user is: www-data.

  • For the Analytics app, try renaming it to "analytics" and see if that works. For the Sitemaps app, try renaming the folder to "sitemap.xml". Let me know how that goes.

    The first looks like a simple typo, but the second should have been clearer about the folder name (I was using it through the installer under Tools > Designer > Install apps/themes in the beta releases). I've updated the readme to clarify that.

  • Aha. Now it works :) Ty.

Sign In or Register to comment.