Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

elefant grid based page editing master

Same issue as before with the original master branch. No add blog just error

Request Method: GET Status Code: HTTP/1.1 302 Moved Temporarily Request Headers 08:12:31.000 User-Agent: Mozilla/5.0 (X11; Linux i686; rv:39.0) Gecko/20100101 Firefox/39.0 Referer: /blog/admin Connection: keep-alive Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8 Sent Cookie elefant_user: 3f4d60ca2fe6999b8b663e8a04be175f elefant_update_checked: 1 elefant_last_page: /title Response Headers Δ216ms X-Powered-By: PHP/5.3.29 Vary: User-Agent,Accept-Encoding Server: Apache/2.2.22 Pragma: no-cache Location: /blog/admin Keep-Alive: timeout=5, max=100 Expires: Thu, 19 Nov 1981 08:52:00 GMT Date: Mon, 20 Apr 2015 20:12:31 GMT Content-Type: text/html Content-Length: 20 Content-Encoding: gzip Connection: Keep-Alive Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Received Cookie elefant_user: 3f4d60ca2fe6999b8b663e8a04be175f elefant_notification: An+Error+Occurred



  • Can you add this line just after the } else { at line 24 of apps/blog/handlers/add.php:

    error_log ('Blog error: ' . $p->error);

    Then look in the Apache error log to see what it shows?

  • This was the error on the server

    [Wed May 13 04:04:25 2015] [warn] [client] mod_fcgid: stderr: Blog error: SQLSTATE[23000]: Integrity constraint violation: 19 _blog_post.tags may not be NULL, referer: /blog/admin

  • I'm getting a similar error with a new MySQL install at the database step: "SQLSTATE[HY000]: General error: 1364 Field 'about' doesn't have a default value"

    If I add default '' to the appropriate line (51) of conf/install_mysql.sql I get "SQLSTATE[42000]: Syntax error or access violation: 1101 BLOB/TEXT column 'about' can't have a default value"

    Changing line 51 to just be about text, (i.e., removing not null) works.

  • Selwyn, I'm guessing that the fix in your case will be similar: allow NULL values in blog_post.tags. You can do that like so: ALTER TABLE blog_post CHANGE tags tags text;

  • Hey twheel, Already tried removing default '' removed not null and still no love. In reference to The master branch had a similar issue - failure to add new blog post. Last time a local database issue was found to be the problem. The current release 1.3.10 and the master branch both contain about text not null, without the add blog post issue?

  • What steps cause the error? Adding a blog post in the default install?

  • Yes, default install of grid based master worked perfectly the first install. Downloaded an updated zip from git and uploaded a fresh install on the server. Add blog post hasn't worked since then. When I extracted the zip the original folder was replaced and overwritten, so can't reference from that. Downloaded a fresh copy and renamed it just in case it was an extraction issue, all raw files and still the same. Just to be sure I also installed a fresh 1.3.10 stable and master branch, both no current issue. Though yet to test all apps. Their defaults and the developer apps seem to be working without complaint. The only error from both of those, hardly life threatening is Use of getPreventDefault() is deprecated. Use defaultPrevented instead.1 jquery-1.8.3.min.js:2:0

  • edited May 2015

    Are you using MySQL? If so, what do you get when you open a MySQL client and run SHOW COLUMNS FROM blog_post WHERE Field='tags';?

Sign In or Register to comment.