Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Polling App

edited September 2014 in Apps

Been working on a native polling app for a few weeks. Finally got it to an operable state. Here's the repository:

It's only the first iteration, and input on it would be most appreciated.


  • edited September 2014

    Thank you BronyBorn, I felt the lack of this app.

    I tried to install it on a fresh Elefant but it seems that there is a problem with the configuration file.

    This is the exact message I get: "Github installation failed: Verification failed: Invalid configuration file."

  • I think you have an issue in your database schema. You're creating an index on the polls table for the column ts that doesn't exist. I'm not sure if the field needs to be added or if the index should be removed.

  • heh, I guess I forgot to refactor the indexes. Just pushed a fix for the schema indexes.

  • After creating a couple polls, the admin page is showing an empty list and the pager info shows:

    1 to 0 of 2 results:

    I tried embedding a poll into a page, but I get a "Loading poll..." that gets replaced with "Unexpected error occurred". The error in the log file is:

    PHP message: Restful error in polls\API->get_poll on line 26: Invalid argument supplied for foreach()

    Hope that helps.

  • edited September 2014

    Both of those are a combination of refactoring and type checking issues. Pushed fixes for both.

    Edit: Found a number of other things that I missed earlier. Made another push. It /should/ work as was intended the first time around...

  • Unfortunately I am not yet able to install it.

    Strangely via github I get the error "... Verification failed: Invalid configuration file."

    while via zip: "... Verification failed: No name specified."

    I am using Elefant 1.3.10 and I've already installed some apps successfully.

  • I just made a pull request with some small changes and spotted a syntax error that I think was preventing the install from working for @alpi.

  • Yes, now I can install it. Thank you both.

  • I just took a ride in the polls app; very nice.

    I noticed three small things:

    • the tables are created without the prefix set in /conf/config.php;

    • a visitor (not logged in) can see the button "Change Vote" although he can not vote.

    • "Question" is not displayed until the user (logged in) votes.

  • Thanks. Just merged the access control fixes and pushed changes to fix the issues alpi pointed out.

  • edited February 2015

    Just pushed an update with a version bump that I feel merits mention here. Notably, adding a custom color for the percentage bars per poll and fixing compatibility so you can embed multiple polls on one page (this change may break some existing custom CSS). There are a few other changes as well listed in the commit description. As always, feedback is appreciated.

Sign In or Register to comment.