Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

zlib and PHP 5.4

I'm having trouble with WAMP Server and PHP 5.4.
Elefant master just downloaded from Github displays a blank page if I do not set compress_output = Off.

Apache error log shows:

[Thu Nov 27 12:56:52.177489 2014] [:error] [pid 11628:tid 800] [client 127.0.0.1:61331] Error in D:\\wamp\\www\\lib\\FrontController.php on line 219: ini_set(): Cannot enable zlib.output_compression - there has already been output
[Thu Nov 27 12:56:52.177489 2014] [:error] [pid 11628:tid 800] [client 127.0.0.1:61331] PHP Fatal error: Uncaught exception 'ErrorException' with message 'ini_set(): Cannot enable zlib.output_compression - there has already been output' in D:\\wamp\\www\\lib\\FrontController.php:219\nStack trace:\n#0 [internal function]: Debugger::handle_error(2, 'ini_set(): Cann...', 'D:\\wamp\\www\\lib...', 219, Array)\n#1 D:\\wamp\\www\\lib\\FrontController.php(219): ini_set('zlib.output_com...', '4096')\n#2 D:\\wamp\\www\\index.php(34): FrontController::run(NULL, NULL)\n#3 {main}\n thrown in D:\\wamp\\www\\lib\\FrontController.php on line 219

WIth PHP 5.3 everything is normal.

I read about this bug
https://bugs.php.net/bug.php?id=61443
but it should be fixed.

Comments

  • edited November 2014
    For now, try disabling gzip by setting `compress_output = Off` in `conf/config.php` and see if that helps.
  • I had already done, and so it works. Thanks

  • I just uninstalled WAMP and installed version 2.4.

    Now it seems working, with compression too.

Sign In or Register to comment.