Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

App/INstall shows empty page

edited March 2014 in Apps

I'm attempting to install both the wiki and events apps into my 1.2.2 build of elefant cms on a newly built LAMPP VPN (for development and prototyping before putting live) but when I hit either of the install 'pages' (wiki/install etc) all I get is an empty page.

Any help is appreciated as I don't think I can commit to elefant until I've got the apps working.

Thanks

Comments

  • I would recommend switching to the latest 1.3 release. It's very close to what will be the final Elefant 2.0 at this point, and it's been running on live sites for some time now without issue.

    It's quite possible that I've updated the Wiki app in a way that broke compatibility with 1.2, since I've been so heavily focused on 1.3 lately...

    On thing that may also help, the documentation for 1.3/2.0 isn't online just yet since I'm still working on the new website, but it is ready and you can read it with the following steps:

    1. In your development copy of Elefant 1.3, run this command:

        git clone https://github.com/jbroadway/elefant-docs.git apps/docs
    

    2. Log in and go to Tools > Navigation. Drag the "Documentation" page into your site navigation.

    You should then see a new "Documentation" link that will take you to the latest documentation.

    Let me know how it goes! :)

  • OK - will give it a go. Thanks

  • Hmmm.... now getting 'env: php: No such file or directory when running ./elephant install'

    Any help would be appreciated.

  • It sounds like your system is most likely missing the php5-cli package. If you're on Debian or Ubuntu, run sudo apt-get install php5-cli and on CentOS or Fedora I believe that would be sudo yum install php-cli.

  • I'm actually using DAmn Small Linux - I believe this is based on debian so should be able to use apt once it's setup correctly. I hope this sorts it out, thanks.

  • OK - looks like php-cli was included in the LAMPP install I'm using but needed to be linked in to the bin to be accessed directly. I now get the slightly worrying message when running '** Error: Installer has already been run.'

    Is there an easy way to uninstall elefant in order to reinstall? Or am I best starting over?

    Thanks.

  • OK - I reinstalled from scratch - making sure that php was definitely available - but it hasn't helped at all. When I attempt to access anything elefant all I get is 'This webpage is not available' from Chrome. Any ideas?

  • Ok - I removed accept-encoding from firefox and I, at least, see the home page now. Unfortunately the admin toolbar doesn't display when logged in and the following displays at the top: Notice: Undefined variable: argv in /opt/lampp/htdocs/index.php on line 32

  • Ok - switched on register_argc_argv in php.ini and changed index.php to use $_SERVER['argv'] rather than $argv and it seems to be working now.

    Finally. It seems that the php message was coming through as clear text as when this disappeared the compression could be turned on once more :)

  • Sorry, there is a warning I forgot about in a change I made in 1.3.9 that is fixed in the latest master on Github where I didn't verify whether $argv/$argc were set. Sorry to waste your time on that one.

    I'm wondering about the accept-encoding issue too. If you disable the compress_output setting in conf/config.php, does that help? And can you see if you have the zlib PHP extension installed?

    I should probably test the install steps against a few more Linux distros. I've been using Debian and Ubuntu mainly for a while, so I should make sure I'm not making any assumptions about the server configuration in Elefant's defaults.

Sign In or Register to comment.