Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

updating 1.3.6 to 1.3.9

edited March 2014 in Apps

I'm trying to update v 1.3.6 from CLI but I get "1.3.6 is already up-to-date".

I think it is normal as check.php returns {"latest": "1.3.6"}

Is there any docs that explains how to update manually?



  • I just added the 1.3.7 updates to the old release system. I made a bit of a mess of the 1.3.7 release though by introducing a bug that breaks the CLI updater. So the steps to update from 1.3.6 to 1.3.9 will be:

    1. Run ./elefant update which should bring you up to 1.3.7 now.

    2. Patch the following line in index.php:

        FrontController::run ($argv);

    3. Patch lib/FrontController.php with this new signature for the run() method:

        public static function run ($argv) {

    4. Run ./elefant update again, which should bring you to 1.3.8 but throw an error on 1.3.9 because of steps 2 and 3. To apply the patch manually, run:

        patch -p1 -i conf/updates/elefant-1.3.8-1.3.9.patch

    It will ask you what it should do about those two files. Answer 'n' to each and you should have a working Elefant 1.3.9 site.

    You can delete the files index.php.rej and lib/FrontController.php.rej and I believe there's a database upgrade to do when you first log into Elefant again, but that should fix the broken updater and bring you up to date.

  • edited March 2014

    I was able to update after moving the site on Linux.

    Now, after having downloaded the updated version (1.3.9) on Windows (WAMP) I have some problems.

    1) Notice: Undefined variable: argv in path\index.php on line 32

    I temporarily solved by putting just before:

    if (! isset ($argv)) {
         $argv = "";

    2) I have to set compress_output = off in order to display pages.

    3) Adding extended field: /admin/extended?extends=Webpage&name=Pages# shows no form (also on Linux).

    Thanks and regards.

  • I believe this commit should fix #1:

    For #2, can you see if changing the last block of code in lib/FrontController.php to this fixes it?

         * Render and send the output to the client, using gzip
         * compression if conf[General][compress_output] is true.
        $out = $page->render ($tpl, $controller);
        if (extension_loaded ('zlib') && conf ('General', 'compress_output')) {
            ini_set ('zlib.output_compression', 4096);
        echo $out;

    And not sure why #3 wouldn't be working. Can you post a screenshot or check if there are any errors in the Javascript console?

  • #1 Right. Solved.

    #2 Yes. Solved.

    #3 Yes, there is a js error due to the presence of a single quote in order_updated (extended:119).

    Three darts, three targets centered. Compliments. Never doubted ;)


  • Everything perfect.


Sign In or Register to comment.