Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Dynamic Objects Disappears

edited December 2013 in Apps

I developed an app with Dynamic Objects in it. There's no issue putting this DOs inside pages, but editing the settings of existing DOs makes it disappear. Sort of like something removed it from the page. So I have to put it again, but this time with desired settings. This doesn't with the old version of Elefant. Was there something I missed? Any fixes I could use?

Comments

  • When does it disappear -- when you edit in Redactor or after you save the page?

  • After changing the Dynamic Object's settings in the Redactor. The DO icon stays but its HTML code disappears.

  • If you click code view (</>), what does it say before you change the settings and what does it say after? For instance, one of my dynamic objects looks like

    <span class="embedded" data-embed="categories/index?type=books" data-label="Category" title="Click to edit."></span>
    
  • Before the change, it's the same as from when I put in the DO. After the change, it's completely gone.

  • I've upgraded Redactor recently, so it's probably a problem resulting from that. I'll look into that and see what's up.

  • I just pushed a fix that seems to be working well for me, so let me know if you still have any issues with the latest master on Github.

  • Thank you very much!

Sign In or Register to comment.