Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Can't log in with chromium

edited July 2013 in Miscellaneous

Working locally, I'm having an odd problem. I can log in fine with firefox but with chromium there's no error message but the admin toolbar is not visible. I'm not quite sure how to debug. Any suggestions?


  • You have both debugs on in the config file? Is this a fresh installation?

  • Is there any difference in Chrome versus Chromium?

  • Sorry, been away. This is on a laptop that's dying; I'm not sure if I'm going to be able to debug further. Chrome isn't currently installed. If I get a chance I will install and test.

    I suspect it was something about the virtualhost environment, cookies maybe (I had apache running on the laptop) because chromium worked fine when logging into a clone of the site running on a remote server, just not when logging into the site running locally.

  • I am on Chromium under Linux...and have no problems. Chrome is also installed on a Windows box I have as well with no issues. Maybe you have some sort of issue with cookies or something. I would try resetting the Chrome/Chromium preferences and settings and see if that helps.

  • I'm having this problem again. To reiterate: if I load http://nickname/ in Chromium, where nickname is defined in /etc/hosts, my login seems to be successful (username and password are not rejected), but the admin bar does not show up. Same thing in a fresh install of Chrome, but no problem in Firefox.

    In Windows running inside of Virtualbox, Opera, Chrome, and IE show the same behavior, but Safari and Firefox log in fine. None of them have any problem with the identical site running at a complete domain name on the internet.

    I'm using apache basic authentication on my local server and I thought that somehow that might be part of the issue, in that Safari, after I log in successfully, asks me a second time for the apache user name and password. However, I turned off apache authentication and still can't login in Chromium, etc.

    OK, figured out a workaround. If I point a fully-qualified domain name at the virtual host running locally, I can log in fine. It seems to be something about http://nickname/ that Chromium, etc. don't like. Maybe cookies don't get set properly.

  • You need to include a dot in the hostname, or cookies won't work across the board. This is a security measure. I use .lo (short for .local, which is what the cookies spec suggests using) or .dev to denote sites on my local machine, such as or

  • OK, thanks.

  • I had the same problem with Chrome and I solved by adding localhost.lo

    in the hosts file and then logging in at http://localhost.lo/admin

Sign In or Register to comment.