Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

admin login problem

edited April 2013 in Install Help

just installed 1_3_4.beta in subdomain ./elefant install appears to work ok and gens db, login user, and pw

../sitepath/admin presents Elefant admin login screen but... login fails and reports bad username or pw tried reinstall with different pw - same result Any suggestions on what to do? Thanks


  • edited April 2013

    Are you using sqlite? I had that problem when the web user couldn't write to conf/site.db.

  • no, using mysql

  • When you go to the /admin login screen and view the source, what does the <form> tag's action attribute contain? And does the default site's homepage come up for you at /sitepath/?

  • here is source for


    clicking on homepage from here gives 'Page Not found' and home link does not respond

    likely something in plain sight that I am missing


    <!DOCTYPE html> Elefant CMS - Please log in to continue.

    Elefant CMS

    Please log in to continue.



    Visit your website.

  • oops = did not send all the html - sorry

    form action is '/GGIC2/admin'

    href for home is '/GGIC2/'

  • I think it's that the cookie is failing to set. Try using instead of localhost, or you can set up a virtualhost for it, which are handy for keeping separate sites for separate projects. But try that URL first and let me know if that works :)

  • ok using

    gives same result, i.e.

    on Elefant admin


    Incorrect email or password, please try again.

    and Home page link is not recognized

    I am running LAMPP and Firefox

    Please forgive me but the virtual host instructions do seem to exactly fit and I am not (yet) an apache power user

    Thanks 4 Yur patience

  • It might be a good idea to try the virtualhost instructions so you can get a site running without the subdomain extras. I think that might help give us a clue where the issue is.

  • Believe I have now set up virtual host correctly - here are settings and result


    Virtual hosts

    Include etc/extra/httpd-vhosts.conf

    /etc/hosts localhost HP2 www.GGIC2.lo


    DocumentRoot "/opt/lampp/htdocs/GGIC2" ServerName www.GGIC2.lo

    then enter url:


    renders the following page:



    Page not found

    Hmm, we can't seem to find the page you wanted at the moment.


    Powered by Elefant CMS Photos by Rachael Hosein

  • Just to make sure, the site is running in the document root of a virtualhost now, but does it have the subfolder script/htaccess mod, or is it a fresh install?

    I'm wondering if it's a database connection problem, since the cookie should be setting and you shouldn't be seeing a page not found error. Try creating a file named apps/test/handlers/db.php with the following code in it, then go to http://www.GCIC2.lo/test/db

    $page->layout = false;
    info (DB::$connections);
    info (DB::fetch ('select id, session_id, expires from #prefix#user'));

    You should expect to see something like this for the output:

        [master] => PDO Object
        [0] => stdClass Object
                [id] => 1
                [session_id] => 0134e7a4cd4b346f5c2d579bb821202e
                [expires] => 2013-05-12 20:02:21

    Let's see what that says.

  • Quick tip: If you indent formatted text in your posts with a tab or four spaces, it'll highlight it to be easier to read. The forum uses Markdown for that :)

  • OK - clearly seems like DB connection problem

    db.php returns only


    following is just a quick test to see if I understand (really basic) Markdown after 1 min intro just a repeat of the db.php code

    $page->layout = false;
    info (DB::$connections);
    info (DB::fetch ('select id, session_id, expires from #prefix#user'));


  • I should have had you add info (DB::error ()); to the db.php file to see the connection error. Add that and it should help you debug your connection.

  • Great - thanks

    error returned is

    SQLSTATE[42S02]: Base table or view not found: 1146 Table 'GGIC_Elefant.elefant_user' doesn't exist

    indeed there is no table 'elefant_user' in the GGIC_Elefant db (there is a table, 'user')

    this would suggest that ./elefant install (which sets up the db tables) is either the wrong one or needs to be rerun or some variation

    created 'elefant_user' in GGIC_Elefant and responded to errors by adding fields id, session_id, and expires; db error is gone but left with only



    Array ( )

    did clean install - got same result

    Seems like 'install' version must not be correct - I will work through here - any suggestions on further steps appreciated

    Thanks for your patience with this seemingly basic issue

  • Hmm, is there a 'user' table? Try executing 'show tables' and see what's there. Looks like you're connecting now, but the database prefix may be off. I'll have to double check that the command line installer is properly setting that when creating the tables.

  • I changed the prefix "elefant_" in config.php to "" to get past the table error reported above

    can now log in to admin

    but .... get no admin toolbar and a lot of garbage on right side of screen ( user added...user deleted..block saved...seemly adding infinite number of these)

    Is there a way to send a screenshot which would be the easiest way to illustrate what is (not) going on?

    Or do the symptoms suggest something else to look at?

  • Glad you can log in now at least! That sounds like a cookie issue with the jGrowl notifications. They should only be displaying once when the action is performed then removed from the list.

    If you try clearing your cookies for the domain and logging in again and editing something, do they start appearing again and again or behave correctly after that?

  • Cleared cookies - logged in again - added another page - and there they are : page created ... page created ... page created ... page created... [close all] clicking [close all] momentarily clears back to one, but then all 4 return

  • What browser and browser version are you using? Gonna see if I can reproduce the issue here

  • Firefox 20.0 on Linux Mint 13

    Also can add new pages but 'add page' hangs although new page was apparently created; i.e. if I back up in browser and go to Tools-Pages, the page just added is there

    Not sure this is not some phpmyadmin issue as I am getting "The extension is missing. Please check your PHP configuration" 'error' in phpmyadmin No specific extension is specified

    It is also complaining that

    $cfg['Servers'][$i]['recent'] $cfg['Servers'][$i]['table_uiprefs']

    are disabled but I don't see how these would be related, but....

  • Hmm, just tested in Firefox 19 and 20 and it works fine here (OSX). Can you find your cookies for the domain and post them here?

    It does sound like you may have other issues with your PHP setup though. Maybe take a look in your Apache or nginx error log and see if there's any clue what might be off.

Sign In or Register to comment.