Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Installing elefant cms on GoDaddy Host,PHP 5.3+with apache server

edited March 2012 in Install Help

Hi, I tried elefent cms installation in the root folder as well as subfolder but the issue is that after successful installation its not giving access to any page of the site, like on admin or index page and showing error message.

The error message is like"The requested URL /index was not found on this server.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Comments

  • It sounds like GoDaddy isn't recognizing the .htaccess file's instructions. I saw this on Google and it may help: Try adding these two lines to the top of the .htaccess file, before the <IfModule mod_rewrite.c>:

    Options +FollowSymLinks
    Options -MultiViews
    

    Let me know if that helps.

  • Thanks for the help but its not working ,the same "page not found error " is shown. I tried elefant cms installation in subfolder and I think we need to change .htaccess. When i view source of file:

    and relative path in reality is, in every css, js file path is showing absolute not relative. if i directly go to ,http://plugin.pleaselogin.me/elefant/css/reset.css then also i can't access file.

    currently htaccess file content is: Options +FollowSymLinks Options -MultiViews Options -MultiViews RewriteEngine On RewriteBase /elefant/ RewriteCond %{REQUEST_FILENAME} !-f [OR] RewriteCond %{REQUEST_FILENAME} .(js|css)$ RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . subfolder.php [L] DirectoryIndex subfolder.php

  • Hi, it's hard to tell since I don't have a GoDaddy account, but hopefully we can figure this out together. I've also seen people mention that it can take up to an hour for GoDaddy's servers to recognize changes to .htaccess. So something that is working may not seem like it at first...

    From what you have, I would try changing the RewriteRule line to this:

    RewriteRule .* subfolder.php [L]
    

    Let's see if that helps.

    Also, if you're just looking to play with Elefant, the easiest way is probably to set up an account with PHP Fog since they offer it as a self-serve, one-click install option. Here's the info about that:

    http://www.elefantcms.com/wiki/Installing-on-PHP-Fog

  • Yaa ,I had seen this but we have only GoDaddy host for our domains, so we can implement it only on GoDaddy host.

  • I see. Did you get to try the latest .htaccess change (RewriteRule .* subfolder.php [L]) and did it help at all?

  • I am having the same issue on my Godaddy account too. I posted a new topic called 403 Forbidden

Sign In or Register to comment.