Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

translation Elefant to Dutch

edited March 2012 in Framework

I have a problem with translating the following line:

Connect & Create Schema

I have tried different things, it seems to be saved but when I go back to that page in the translation tool the field is empty again. It seems it has something to do with the & which I just copy. There is another line with the same & and this line gives the same problem.

Furthermore, second question, in Dutch it would be then :

Verbinden & Creëer Schema.

Is using the ë (with the double dot on top) ok or should I use the special htmlcode for this?

Comments

  • Hmm, that's odd. Are you using the very latest source from GitHub? I wonder if there might be new updates that would fix the & issue.

    Testing it here on the latest GitHub source, I can enter & just as &, and letters like ë work fine too (no special codes).

    If that doesn't help, what version of PHP and what browser are you on?

  • 2 days ago I downloaded 1.2 version but there the translation app was missing. So I took from Github again a 1_1_3_beta version in which I did found the translation tool.

    I use PHP Version 5.3.9-ZS5.6.0 on Google Chrome

  • I have tried also in Firefox and also a single & and the corresponding htmlcode. But both did not work. If necessary I can use just "and" instead of the &.

    There are three lines with the & sign problem. The rest of the Dutch translation is ready.

  • I see. I'd recommend grabbing the very latest from this link and seeing if that fixes it:

    https://github.com/jbroadway/elefant/zipball/master

    I believe the issue should be fixed in that one. To move your translations over, copy the Dutch file in the lang/ folder as well as the Dutch settings in lang/languages.php. Let me know how it goes!

  • Sorry, still no luck

  • Can you post the lang files to http://gist.github.com/ and that should tell me what it's doing wrong behind the scenes.

  • Did it. git clone git@gist.github.com:8d00a793352f06412543.git gist-8d00a793

    Before pasting it into Git I checked the file itself and found out that in the Dutch translation instead of & there was @. I changed those by hand.

    Dutch translation should be ok now.

  • Awesome! I wonder why it would enter an @ instead of a &, that's very odd... I'll have to experiment with my browser settings to see if it's an encoding quirk or something like that.

    Just fetched the translation and it looks great! I have two things to ask though:

    1. It's showing me 88% translated, which I think is happening because your translation index needs updating. If you click the "Rebuild index" link in the Translator app, that should update it with any missing strings.

    I should document this too so it doesn't catch others. Sorry about that.

    1. What would you like to show up on the contributors page :)

    http://www.elefantcms.com/wiki/Contributors

    Thanks!!!

  • Ok.

    1. I now did "Rebuild Index". There are no other new lines. After that, the three lines with the & are still empty and I cannot fill them. After entering a text it says "saved" but moving to the next page and back shows the inputfield empty again.

    And next to line "Extra options" there is no inputfield at all. This line was also missing in the language file, so I entered it manually on the first line. The three lines with the & sign I entered the Dutch translation also manually as well already the first time.

    Here you find the new copy: git@gist.github.com:6aa3496dd58f96ec4bb8.git gist-6aa3496d

    1. I appreciate it very much that you will mention us on the contributers page as: Golden Value/Basehosting Netherlands with this link www.goldenvalue,nl.

    After this translation I move on to finishing the artisteer template.

    Thanks!

  • Thanks, I've updated the Dutch language file and added you to the contributors page. I see the missing input next to "Extra options" and I'm going to do some more testing on the translation app to solve these. Thanks for all the help!

Sign In or Register to comment.