Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

problem with compress_output = On

edited May 2013 in Framework

Just after a new installation with compress_output set to "On" (by default) accessing the site, browser is unable to manage the compression.

I have to change something on the server?

Setting compress_output set to "Off" it seems to work properly.

Thanks.

Comments

  • Can you see if this edit fixes it? Try replacing the last block of code in index.php with this:

    $out = $page->render ($tpl, $controller);
    if (extension_loaded ('zlib') && conf ('General', 'compress_output')) {
        $zlib_oc = ini_get ('zlib.output_compression');
        if ($zlib_oc === '' || $zlib_oc === 'Off' || ! $zlib_oc) {
            ob_start ('ob_gzhandler');
        }
    }
    echo $out;
    

    If that works, then it's a conflict between the zlib.output_compression setting and ob_gzhandler. If not, it might be a conflict with a setting in Apache.

  • Solved, thanks. So have I to solve the first mentioned conflict?

  • If it's working with compress_output turned on, then I think you're all good now :)

  • Yes it is. Thanks!

  • Hi newly installed v1.3.5 locally (on WIndows 7 with last WAMP) with the same compression problem. In this case the fix above doesn't solve.

  • Googling around a bit, it sounds like you may want to try disabling PHP's output_buffering setting, or if that doesn't work, you may have to turn compress_output off in Elefant. Seems other PHP users have had similar issues on Windows in the past.

Sign In or Register to comment.