Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Tools > languages gives an 500 Error

edited December 2012 in I18n

I just downloaded the latest git Version of elefant.

I wanted to create a multilingual Page, so I read the tutorial:

But when I try to open the languages Menu in Tools I get a 500 Error.

This is the url which produces the error:

Did I miss something to get started?


  • Im using a subdomain. Can this cause the problem?

  • Shouldn't be a subdomain issue. If you turn display_errors and debug on in conf/config.php does it show any additional clues?

  • Yes there is some big clue :-) I posted it on gist:

    It has something to do with the sources...

  • What happens if you add this right before the foreach?

    $files = is_array ($files) ? $files : array ();

    Does the rest of it run successfully then?

  • This worked! Thanks a lot for that. Does this solve the issue completly? Because you are talking about the rest running:-)

  • By the way if you need a translation in german I could do one, not now but sometimes.. :-)

  • A German translation would be awesome! And yes, I meant whether the rest of the script ran successfully after that, which it sounds like it did :)

  • Yes it did ! Thanks a lot for the super quick help..

  • Sorry to bother again:

    I got two other issues:


    {! navigation/section?section=[constant('HOMEPAGE')] !} is rendered to this:

    <?php echo $this->controller->run ('navigation/section', array ('section' => Template::sanitize (constant(\'HOMEPAGE\'), 'UTF-8'))); ?> 

    Which throws an error because the Quotes don't need to be escaped at that point. I guess the glitch is in your magic regex..


    When I try to edit my Settings in Language German I get this error.:

    At the moment I can delete and recreate the language to change settings, but that's of cause not the elefant style :-)

  • I am at 19% on the German translation. Started it a while back but never finished. Actually working on it again. @betaman, do you want to take N - Z? That's splitting it in half...then we can merge the two together. You can email me the de.php file to and then we can submit it to the master. Is that okay @jbroadway?

  • sure, im a little bussy at the moment, but it wont last 4ever. When the buzz is over I'll start with N :-)

  • Okay...I'm finished with the German translation. Decided to continue with it. I am sure it may need some tweaking. Despite studying German for 4 years, it's been almost 20 years since last taking it. @jbroadway Since I don't know how to properly use Github, I will email you the de.php and language.php files for you to add.


  • First, thanks for the translation @jmonroe! I just committed it to Github and added you to the contributors page :)

    For the first issue, are you using the latest Elefant master or an earlier release? Because it seems to be working in the latest master for me:

    The compiled template in conf/test-const.php is shown there with the quotes preserved correctly.

    The other issue looks like it was caused by an extra slash in the URLs, causing the auto-linking of form handlers to view templates to fail in translator/settings. I committed a fix for this just now too.

  • @jbroadway Thanks bro!! Glad I could help. I am using the latest from github. It's the test site I sent you the credentials to the other day. That's straight from github. I get the same error that betaman has reported in regards to the settings button not working.

  • Now I just need to start rolling out some templates. Did you ever get to look again at the new version of the bootstrap theme I sent you? I know you said some issues existed but wasn't sure which. Can you relay that to me again please so I can see about fixing them? Thanks.

  • I think the main thing was just the unstyled navigation in the header, and I see the blocks near the bottom don't have an id value. Otherwise, looks alright to me.

  • Alright...well let me look at it again today. I will figure out what's wrong and get it back to you.

  • i got the unstyled navigation figured out. I am not liking the table layout though. Its bunching things together even though I changed the container from 940px to 100%. Little more time and should have it ready.

  • Hi guys, i was away in Berlin for a few days. and I'm heading back home now.. @jbroadway thanks for the fix 2) it worked .-) 1) didn't but i didn't investigate this further, i worked myseld around it. I will Post it when i'm home again.

    @jmonroe thanks for sparing me the n-z. ;-)

    As i see, there is some progress in the redactor, im pretty excited about it, and can't weit to check it out... (<- ambiguous :-)

  • Glad to have you back, and yes there's been a little progress on Redactor. I have a couple questions into their support right now, the API documentation is a little light for what we're trying to do with dynamic embeds for example, so I'm waiting to hear how they recommend doing it. Hope I hear back soon though, I really want to work on this right now! :)

  • Yeah, I can believe that you want to get on with it... Let's hope the support is as beautiful as the redactor himself :-)

  • Hi Johnny,

    I want to take on the path navigation stuff and the I18n with negotiation_method = url

    I made a clean install from master and ecnountered this problem again:

    I made a gist which shows the problem:

    Please look at it again, although i now it might be a bit anoying. But I just did it the way written in the Documentation and others might be scared off from elefant, cause its not working like expected.

    Cheers Jens

  • Was hoping I'd have time to look into this today, but work kept me too busy. Will try sometime over the weekend or else on Monday. Have a good weekend!

  • Great. Have a nice Weekend as well, and do it on monday .-)

Sign In or Register to comment.