Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Current Master Branch

edited October 2012 in Framework

Just did a new pull on the current master branch, be careful using it. I am getting a lot of intermittent 500 errors. Every 4 out of 5 page loads is 500s.

I will get more details when I have a chance. (Have to get a client site started and done by tomorrow afternoon)

Thanks!

Comments

  • Hmm, a fresh clone seems to be working fine here (stock Apache 2.2.21/PHP 5.3.10 on OSX 10.7). Let me know if you see any specific error messages!

  • I was running from a MAMP Pro, Using PHP 5.4.4 on OSX 10.8.2. The 1.3.2 beta run perfectly fine. Same exact settings, no errors at all.

    I will take another look when I have more time! Sorry, I am just stupid busy. 19 credit hours of 300-400 level computer science classes and 20+ hour of work a week will kill a person.

  • edited January 2013

    Did some more digging into this. (On redactor branch, but same results as current master)

    [06-Jan-2013 22:56:26 UTC] Error in /Users/shortjared/elefant_git/redacto/index.php on line 154: ob_start(): output handler 'ob_gzhandler' conflicts with 'zlib output compression'
    [06-Jan-2013 22:56:26 UTC] PHP Fatal error:  Uncaught exception 'ErrorException' with message 'ob_start(): output handler 'ob_gzhandler' conflicts with 'zlib output compression'' in /Users/shortjared/elefant_git/redacto/index.php:154
    Stack trace:
    #0 [internal function]: Debugger::handle_error(2, 'ob_start(): out...', '/Users/shortjar...', 154, Array)
    #1 /Users/shortjared/elefant_git/redacto/index.php(154): ob_start('ob_gzhandler')
    #2 {main}
      thrown in /Users/shortjared/elefant_git/redacto/index.php on line 154
    

    Quick fix for this was to revert to PHP 5.3.14.

  • That's a strange message. Another fix could be to set compress_output to Off in the global config to disable the output compression, but the zlib extension is what provides the ob_gzhandler support... Might be related to one of these PHP bugs:

    https://bugs.php.net/bug.php?id=62335 https://bugs.php.net/bug.php?id=55544

  • Yeah. Odd. And it only happens occasionally. For instance one time I might get a 500 error altogether, the next the main page may load, but then when JS retreieves the admin toolbar content via ajax, that part will throw a 500 error. The next refresh it may all work perfectly fine. No rhyme or reason to any of it.

Sign In or Register to comment.