Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Designer Bug

edited June 2012 in Apps

I think I found the bug that jmonroe ran into. If you try to set an item to default that is not in the root directory, when it updates the default_layout in the conf/config.php file it does not add the appropriate directory so can no find that file.

Looking for the fix right now.


  • Check out Check out the blog and contact page...they are taking on the templates form and stylesheet but the index page is not. This is driving me insane. I cannot figure out the deal.

  • It has something to do with the defaults I believe. I am running into quite a few issues. The quickest way to solve this is to just put everything you need in the main layouts/ directory. Don't use anything deeper than that right now. There is something going on with the designer files. I messed with it a bit but didn't have time to find a permanent fix yet.

  • So you mean put all the files? including the js files? I only have one html file in there. I don't have separate html files.

  • Not exactly.

    Can you double check your actual blog and contact pages and make sure that under the extras you actually explicitly tell it what layout to use?

  • I'm not. It's set to use default

  • I have my index page set to mytheme, blog set to mytheme/blog and contact is mytheme/contact. Only the index page is displayed correctly.

  • Yeah. You'll have to probably move those from mytheme/blog to just the root layouts and just have blog. We need to rework the layouts. Something is screwed up. I'll open an issue on github and try to take a look this weekend.

  • I just pushed a commit that should fix this issue. It was taking the basename($file, '.html') of the layout, which stripped out the folder name. I just added the folder name back in if it was different than the basename of the file.

  • ShortJ...what I mean is that all my html files are under the root of the theme directory. I was stating that when you click on Extra Options under each page edit, it list it as mytheme, mytheme/blog, and mytheme/contact as the three layouts you can choose. They all did reside under the mytheme folder. The only files that reside elsewhere are css (minus main stylesheet), js and image files. So my folder structure is mytheme-->mytheme.html, blog.html, contact.html, elefant.json, style.css, Folder -->css, images, js.

    Thanks for looking into it jbroadway. I am going to do a pull now. Will let you know if I see anything else wrong.

  • edited June 2012

    I cannot figure out how to do the pull to get the update changes down to my local repository so i can reupload to my server. I am using Github desktop app for windows. It says I am in sync however, the last history insert is from May 24 Fixed missing urlify.js include.

  • Looks like it works for me now. The Extra Options are all set to default layout. And the html files have the references to which stylesheet to the pages are acting and look as should. Thanks.

  • I have tried a few different themes and they all seem to be working correctly. I feel like I have gained a little sanity back! I couldn't figure out what I was doing wrong and I am too much of a novice to state that it was my lack of knowledge. Really glad you found the issue J.

  • @jbroadway. I had fixed that on my local yesterday but for some reason I was thinking there was something in the way it set the default or pages or something that also needed to be changed. I'll double check. Maybe I was just seeing things. That happens.

    Ah well. If it works now that's good!

  • It does work. But how do I go about pulling down the revised files and upload without overwriting all other files? I couldn't figure it out through github desktop app so I redownloaded it and uploaded all the directories except my conf. It all works now but I would like to learn the right way.

  • Does the desktop app have a way to do the git fetch and git merge functions?

    I usually just do (command line)

    git fetch upstream
    git merge upstream/master
  • Not sure...I was looking around at it. It has a sync icon but that doesn't seem to work. I was looking for an upstream option but didn't see that either.

  • You need to add a remote repo titled upstream for the commands that I listed to work..

    git remote add upstream git://
Sign In or Register to comment.